Exchange 2010 Error applying Service Pack “Setup previously Failed while performing action Install”

I encountered this error while performing an install of an Exchange 2010 Service Pack:

Some controls aren’t valid.
– Setup previously failed while performing the action “Install”. You can’t resume setup by performing the action “BuildToBuildUpgrade”

Exchange 2010 BuildToBuildUpgrade Error

To fix the issue, we need to open the registry, find and remove the offending key.

1) Open the Registry editor START – RUN – regedt32
2) Navigate to HKEY_LOCAL_MACHINESOFTWAREMicrosoftExchangeServerv14
3) Look at each of the Dozen or so entries. You will find one or more that has a key call Action with Value Install
4) Delete every Action Key with Value Install.

Rerun the setup and you should be good to go.

Bookmark the permalink.

7 Responses to Exchange 2010 Error applying Service Pack “Setup previously Failed while performing action Install”

  1. mirko says:

    Well done – it was doing my head in.

  2. MDCT says:

    First time I have ever ran across this. Worked in my test env.
    Thanks!

  3. Joe Beatty says:

    Deleting the key worked like a charm on Windows 10. Thank you so much!

  4. nichomach says:

    Nice – Management Console was giving me fits!

  5. Chris Baumann says:

    Nice work this was a godsend! Thank you!

  6. A.R. says:

    it works great

  7. Tim says:

    Thanks a ton… worked perfect!

Leave a Reply

Your email address will not be published. Required fields are marked *

Solve : *
18 + 15 =